Sitemap generator for RoboHelp

Installation and use

Willam van Weelden



Copyright 2014, WvanWeelden Consultancy. All rights reserved.

No part of this document may be reproduced, transmitted in any form or by any means without the
prior written permission of WvanWeelden Consultancy.

www.wvanweelden.eu

Copyright 2014 - All rights reserved 2 of 21 www.wvanweelden.eu


http://www.wvanweelden.eu

WvanWeelden
Co yltancy

LOnsit

Table of Contents

YL =10 T e [ 4 =T Lo 1 R 4
S UL T Te IR d o TS of o ) TR 5
(@1 o To T U] 1 (= 4 - o J O 6
(O = IR o g LT 1 =T o T Vo Y 6
Automatically create sitemaps 0N geNEratioN .......cc.vviuiieiiiieii e e e e e e e eanes 9
Set the URL for every Single SOUrCe LaYOUL ....c..uiiiiiuiiiiiiiii e e e 9
Set the script to run automMatiCally ......ooeeeueiiiiii e 11
Stop the script from running automatically ... 12
Create sitemaps for merged help ... e e 13
Submitting your sitemap to a search eNgiNe ........ccooeu i 16
2] 0T Y 16
(oo o | 1TSS 18

Copyright 2014 - All rights reserved 3 of 21 www.wvanweelden.eu


http://www.wvanweelden.eu

Sitemap generator

Thank you for purchasing the sitemap generator for RoboHelp. With this script you can
create sitemaps for your help content, thus allowing search engines such as Google to

index your entire help.
The Sitemap generator supports the following outputs:

e FlashHelp

e FlashHelp Pro

e Multiscreen HTML5
e Responsive HTML5
e WebHelp

e  WebHelp Pro

The following files are added to the sitemap and will be indexed:

e .htm/.html: RoboHelp topics and imported files.
e .doc/.docx/.rtf: Word files.
e .pdf: PDF files

e .xls/.xslx: Excel files

If you have any questions regarding this script, or if you need help with RoboHelp,

don’t hesitate to contact me.
Willam van Weelden

www.wvanweelden.eu

This script saves your settings in an XML file in the project directory
A (scriptSettingFile.xml). This file is not added to the RoboHelp project and is also not

added to version control. Be sure to retain this file, otherwise your settings will be lost.
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Installing the script

To use the script, you must first import the script into RoboHelp:

1. Open any RoboHelp project.

2. Open the Script Explorer. You open the Script Explorer by clicking View >
Pods > Script Explorer.

3. In the Script Explorer, click on the blank space below the scripts so that no

script or directory is selected.

. Script Explorer @
mﬁﬁl H/Xﬁlﬂ E

-] Sample Scripts

4, Click the Import Script files ( L ).
5. In the file picker, select the SiteMapGenerator.jsx file and click Open.

Script Explorer @
w2 X e g

__ Sample Scripts
L[l SteMapGenerator jsx

The script is now imported into RoboHelp. See “Creating a sitemap” on page 6 and
“Automatically create sitemaps on generation” on page 9 for more information on how

to use the script.
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Creating a sitemap

Before you create a sitemap, you need to know the URL where the help will be
published. This is important, because a sitemap requires the full URL of all the files in
your output. Therefore, you need to set the URL for every Single Source Layout where

you want to include a sitemap.

The URL you need, is the full URL of the help once it is published. For example: The

start file of your help is:

http://www.example.com/help/index.htm

The URL that you need to set in the Sitemap generator is:

http://www.example.com/help/

Be sure to include the full directory and the ending slash.

The URL must be set correctly for every Single Source Layout. If the URL is set
incorrectly, search engines will not be able to read the sitemap.

Create the sitemap

You create a sitemap as follows:

1. Open the RoboHelp project where you want to create a sitemap for.
2. Open the Script Explorer. You open the Script Explorer by clicking View >
Pods > Script Explorer.

Script Explorer @
Cimd s X f

-] Sample Scripts

3. Select the Sitemap generator script and click Run Selected Script File (Hlﬁ).
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Sitemap generator

WebHelp_for CHM_with_Skin Settings for SSL WebHelp_for_CHM_with_Skin
Muttiscreen_HTMLS_Sic_Devices
Muttiscreen_HTML5_Desktop
WebHelp_Content_Categories
WebHelp_CSH_TOC_Based_Layout hittp://Awww example com/

The URL where the help will be published:

How often does the cortent change:

weekhy -

The URL of the help must be the full path to the help.
Example: http://www example.com/help/projectname/
The sitemap will onby work with a complste URL.

Autorun is enabled. Click to disable.

Version 2013-05-06 - Copyright Willam van Weelden - www wyanweelden eu

Generate Stemap ] [ Save ] [ Cancel

4. In the left pane, select the Single Source Layout for which you want to

generate a sitemap.

5. Add the URL of the help in field URL.
6. Choose how often this content changes.
7. Click Generate Sitemap. (Your settings are automatically saved.)

&% Do you want to generate the 550 WebHelp_for_CHM_with_Skin before
W' creating the sitemap.

8. If you want to generate the output before creating a sitemap, click Yes.
Otherwise click Cancel or No. (Name may vary per installation.)
9. The sitemap is created when the script shows the following alert. Click OK to

return to the sitemap generator.
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:I Sitemap created.
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Automatically create sitemaps on generation

RoboHelp 10 supports automatic creation of sitemaps whenever you generate your
output. This makes the sitemap generate a true set-and-forget solution. In automatic
mode, the script will never give you a popup, it will just create a sitemap when needed.

In the Output View pod, the script will notify you when a sitemap is created:

i Qutput View -~ 8 X
= h
Processing context-sensitive help data... -

Applying screen layout page (Topic) to topics...
Applying to First_Topic htm...
Applying to Second_topic htm...
Applying to Third_topic htm...
Finizshed applying screen layout page (Topic) to topics in 1 secis) : Total 3 topicis).

Processing "Search results page” search screen layout page. ..
Finished compiling Multiscreen HTMLS output in 5 secis)

Sitemap created. e
lCompiIation complete.

m

To use the sitemap generator as an automatic solution, you must set the URL for all

Single Source Layouts and you must set the script to run automatically.

Set the URL for every Single Source Layout

1. Open the RoboHelp project where you want to create a sitemap for.
2. Open the Script Explorer. You open the Script Explorer by clicking View >
Pods > Script Explorer.

Script Explorer a

-] Sample Scripts

3. Select the Sitemap generator script and click Run Selected Script File (L.'Al:l).
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WebHelp_for CHM_with_Skin Settings for SSL WebHelp_for_CHM_with_Skin

Muttiscreen_HTMLS_Sic_Devices
Muttiscreen_HTML5_Desktop
WebHelp_Content_Categories
WebHelp_CSH_TOC_Based_Layout hittp:/Awww example com./

The URL where the help will be published:

How often does the cortent change:

weekhy -

The URL of the help must be the full path to the help.
Example: http://www example.com/help/projectname/
The sitemap will onby work with a complste URL.

Autorun is enabled. Click to disable.

Version 2013-05-06 - Copyright Willam van Weelden - www wyanweelden eu

Generate Stemap ] [ Save ] [ Cancel

4. In the left pane, select the Single Source Layout you want to generate a
sitemap for.
5. Add the URL of the help in field URL.

o

Choose how often this content changes.

N

Repeat step 4 to 6 for every layout you want to automatically create sitemaps
for.

8. Click Save.

Script Alert [

9. Click OK.

The settings are now saved for the Single Source Layouts in this project. If you want to
automatically create sitemaps for other projects, repeat the steps for every project. If

you are done, continue with the section “Set the script to run automatically”.
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Set the script to run automatically

The sitemap generator interface contains the button Autorun is disabled. Click to

enable. Click the button to make the script run automatically in the background.

T P35
Sitemap generator ! J

WebHelp_for CHM_with_Skin Settings for SSL WebHelp_for CHM_with_Skin
Muttiscreen_HTML5_Six_Devices

Muttiscreen_HTML5_Desktop ; : .
ViebHelp_ Cortent_Categories The URL where the help will be published:

WebHelp_CSH_TOC_Based_Layout hitp:/Awww example com/

How often does the content change:

weekly -

The URL of the help must be the full path to the help.
Example: http://www example.com/help/projectname/
The sitemap will onby work with a complete URL.

Autorun is disabled. Click to enable.
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Generate Stemap ] [ Save ] [ Cancel

If you do not see the Autorun is disable. Click to enable, you are using RoboHelp 8 or
9. These versions of RoboHelp do not support the automatic mode of this script.
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Stop the script from running automatically

If you have set the script to run automatically in the background, the sitemap
generator interface will show the button Autorun is enabled. Click to disable. Click the

button to stop the script running automatically.

Sitemap generator

WebHelp_for CHM_with_Skin Settings for SSL WebHelp_for CHM_with_Skin
Muttiscreen_HTML5_Six_Devices

Muttiscreen_HTML5_Desktop ; : .
ViebHelp_ Cortent_Categories The URL where the help will be published:

WebHelp_CSH_TOC_Based_Layout http://www sxample com./

How often does the content change:

weekly -

The URL of the help must be the full path to the help.
Example: http://www example.com/help/projectname/
The sitemap will onby work with a complete URL.

’ Autorun is enabled. Click to disable.

7

~
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Generate Stemap ] [ Save ] [ Cancel
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Create sitemaps for merged help

You can create sitemaps for merged help. For merged help, you need to manually
create a sitemap after every help generation. This is a limitation of the way merged
help works.

To create a sitemap for merged help, follow these steps:

1. Generate your master project. Make sure that you leave the project in the
directory RoboHelp generated the project.

2. Generate all your child projects. Paste the generated child projects in the
folder mergedProjects of the master project.
Open the master project.

4. Open the Script Explorer. You open the Script Explorer by clicking View >
Pods > Script Explorer.

Script Explorer @
Ciida 2 X 6 ls [

(-] Sample Scripts

5. Select the Sitemap generator script and click Run Selected Script File (L.'Aﬂ).
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WebHelp_for CHM_with_Skin — Settings for SSL WebHelp_for_ CHM_with_Skin
Muttiscreen_HTMLS_Sic_Devices

Multiscreen_HTML5_Desktop ] ) .
ViebHelp_Content_Categories The URL where the help will be published:

WebHelp_CSH_TOC_Based_Layout hittp:/Ywww example com.’

How often does the cortent change:

weekhy -

The URL of the help must be the full path to the help.
Example: http://www example.com/help/projectname/
The sitemap will onby work with a complste URL.

Autorun is enabled. Click to disable.

Version 2013-05-06 - Copyright Willam van Weelden - www wyanweelden eu

Generate Stemap ] [ Save ] [ Cancel

6 In the left pane, select the Single Source Layout of the master project.
7 Add the URL of the help in field URL.

8. Choose how often this content changes.
9

Click Generate Sitemap. (Your settings are automatically saved.)

% Do you want to generate the 550 WebHelp_for_CHM_with_Skin before
W' creating the sitemap.

10. Click Cancel or No. (Name may vary per installation.)
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11. The sitemap is created when the script shows the following alert. Click OK to

return to the sitemap generator.

p
Script Alert (=3

Copyright 2014 - All rights reserved 15 of 21 www.wvanweelden.eu


http://www.wvanweelden.eu

Submitting your sitemap to a search engine

When you have created the sitemap, you are almost done. After you publish your help,

the last step is to make you site known to search engines such as Bing and Google.

You only need to submit your sitemap once. Whenever you update your help and your
sitemap, the search engine will automatically pick up any changes.

This chapter lists the steps required to submit your sitemap to Bing and Google.
Normally, this is something your website administrator must do for you.

Bing

1. Go to the Bing webmaster toolbox page: www.bing.com/toolbox/webmaster
2. Log in using your Microsoft account.
3. In the sidebar, click Add a Site.

blﬁg Webmaster

My Sites

Add a Site
Dashboard

» Configure My Site

» Reports & Data

» Diagnostics & Tools
» Messages
Webmaster API

Privacy and Cookies Legal Advertise Help Feedback Community
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4. In the field URL, add the URL of the site that contains the help. Only point to
the root of the site. For example: http://www.example.com/help/

5. In the field Add a sitemap, add the URL of the sitemap. This is the same as

the URL, only add the text sitemap.xm/. For example:
http://www.example.com/help/sitemap.xml

blﬁg Webmaster

proFite  wessacesB wer@ o)
Add a Site
ABOUT MY WEBSITE
URL*
Add a sitemap @
When do you receive the most traffic to this site for your local time of the day? 0
All Day (Default) [+
ADD
Privacy and Cookies Legal Advertise Help Feedback Community
6. Click Add.
7. Follow the steps indicated by Bing to verify that you are the owner of the site.

The sitemap is now submitted to Bing and the search engine will index your site.
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Google

1. Go to the Google Webmaster Tools page:

https://www.google.com/webmasters/tools/home

2. Log on using your Google account.

Search Images Maps Play YouTube News Gmail Drive Calendar More ~

GOL)gle 0 || + Share .-

Webmaster Tools Help ~
I Home
Sort: | By site health  Alphabetically ADD A SITE o
All Messages
Preferences
» Labs

Other Resources

3. Click Add a site.
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Search

Images

Add a site

Enter the URL of a site you'd like to manage

Cancel

In the field URL, add the URL of the site that contains the help. Only point to
the root of the site. For example: http://www.example.com/help/

Click Continue.
Follow the steps indicated by Google to verify that you are the owner of the

site.

Maps Play YouTube News Gmail Drive Calendar More ~

Google
Webmaster Tools

I Dashboard
Messages
+ Configuration
» Health
» Traffic
» Optimization

v Labs

Copyright 2014 - All rights reserved

0 + Share .v

Help =

MNew and important

Mo new messages or recent critical issues. View all

Current Status

Crawl Errors » Search Queries » Sitemaps

No data available. (WWhy nat?) No data available. (Why nat?) V submit a Sitemap?

Go to the dashboard and on the right site, click the section Sitemaps.
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Search Images Maps Play YouTube News Gmail Drive Calendar More ~

GO\)gle n| 0 + Share .v

Webmaster Tools Help =
Messages
By me (0) All (D)
» Configuration Mo sitemaps found for this site
v Health
» Traffic

~ Optimization
I Sitemaps
Remave URLs
HTML Improvements
Content Keywords
Structured Data
Data Highlighter

Other Resources

» Labs

8. Click Add/Test Sitemap.

Search Images Maps Play YouTube News Gmail Drive Calendar More ~

GO;)S]Q 0 || + Share .v

Webmaster Tools Help =
Dashboard Sitemaps
Messages .
g By me (0} All (0) AddTest Sitemap
R .
Configuration Mo sitemaps found for this site. hittp:// !
» Health

Test Sitemap Cancel
» Traffic

~ Optimization
I Sitemaps

Remaove URLs
HTML Improvements
Content Keywords
Structured Data
Data Highlighter
Other Resources

v Labs

9. Add the text sitemap.xm/in the field.
10.  Click Submit Sitemap.
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11.  Click the link Refresh the page to refresh the status of the page and see

whether your sitemap was successfully submitted.

The sitemap is now submitted to Google and the search engine will index your site.
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